2
Vote

Support for Vista or Windows 7

description

iPodShuffleSync to run on Microsoft Vista or Windows 7.

comments

PedroLuz wrote Jun 28, 2009 at 3:17 PM

Go for Vista!

wrote Feb 18, 2010 at 1:18 AM

wrote Feb 13, 2013 at 9:41 PM